Detaildarstellung Bearbeitungsmenü

Geschätzte Lektüre: 10 Minuten

Datei

Info

Information, wann und von wem der Datensatz angelegt bzw. geändert wurde, sowie eine Übersicht über die Tastenkombinationen (short cuts), die in dieser Ansicht zur Verfügung stehen.

Abb.1: Datei / Info

Erläuterung zu den Tastenkombinationen

übernehmen + vorheriger = Es werden die Änderungen übernommen und der vorherige Datensatz angezeigt
übernehmen + nächster = Es werden die Änderungen übernommen und der nächste Datensatz angezeigt
übernehmen + anlegen = Es werden die Änderungen übernommen und ein neuer Datensatz angelegt

History

Anzeigen, wann und von wem der Datensatz bzw. bestimmte Datenfelder geändert wurden, sowie der alte und neue Wert des Datenfeldes. Die durchgeführten Änderungen werden nur für ausgewählte Tabellen und Datenfelder protokolliert.
Dies wird vom Admin definiert. Gibt es für einen Datensatz keine History, wird der Menüpunkt nicht angezeigt.

Abb.2: Datei / History

Speichern

Durchgeführte Änderungen werden gespeichert.

Neu anlegen

Legt einen neuen Datensatz an. Dabei sind 2 Varianten zu unterscheiden. Welche Variante Anwendung findet wird vom Administrator je Tabelle festgelegt.

Variante 1:

Nach Auswahl der Funktion ‚Datei neu anlegen‘ erscheint ein Fenster mit der Frage ‚WOLLEN SIE EINEN NEUEN DATENSATZ ANLEGEN‘.
Wird diese Abfrage mit OK bestätigt, wird eine Datensatz-ID vergeben und ein leerer Datensatz angelegt. Dieser Datensatz kann jetzt weiter bearbeitet werden. Es empfiehlt sich NICHT, leere Datensätze anzulegen.

Variante 2:

Erst nach Eingabe der Daten und anklicken der Schaltfläche übernehmen wird ein neuer Datensatz angelegt.

Kopieren

Der Datensatz wird kopiert, aber nur vom Administrator festgelegte Datenfelder werden berücksichtigt.

Drucken

Die Druckfunktion des verwendeten Browsers wird aktiviert. Der Bildschirminhalt wird auf Drucker oder in Datei ausgeben.

Versionieren

Anlage einer neuen Version eines Datensatzes. In der Demo-Anwendung kann die Versionierung beispielsweise bei der Tabelle Artikel näher angesehen werden.
Nach Aufruf der Funktion VERSIONIEREN erscheint ein Bestätigungsfenster am Bildschirm. Die Versionierung kann hier bestätigt oder abgebrochen werden.

Wird der Datensatz in der Detailansicht versioniert, kann zusätzlich ein Hinweistext (z.B. Grund für die Versionierung) eingegeben werden. Nach Bestätigung der Abfrage „verschwindet“ die aktuelle Version des Datensatzes.
Die neue Version wird am Ende der Tabelle angelegt. In der Detailansicht eines Datensatzes kann am rechten oberen Rand des Bearbeitungsfensters gesteuert werden, welche Version des Datensatzes angezeigt werden soll.
Um die versionierten Datensätze anzuzeigen, wählt man in der Listenansicht unter Ansicht den Menüpunkt „zeige versionierte“ aus.

Die versionierten Datensätze werden nun zusammen mit den anderen Datensätzen in der Tabelle angezeigt. Dabei stehen die verschiedenen Versionen eines Artikels nacheinander aufgelistet.
An erster Stelle der Tabelle gibt es nun eine weitere Spalte, die die Versionsnummer des Datensatzes anzeigt. Bei versionierten Datensätzen ist diese Versionsnummer rot.

Versionen können auch maschinell verglichen werden. Siehe dazu MENÜ ->EXTRAS ->VERGLEICHE MIT. Zu beachten ist dabei, dass ein Versionsvergleich nur in der Detailansicht möglich ist.

Unter Menü->Extras->Versionsstand besteht auch die Möglichkeit, sich den Versionsstand zu einem bestimmten Termin anzeigen zu lassen.

Archivieren

Selektierte Datensätze werden archiviert. Archivierte Datensätze werden bei der Standard-Listenansicht nicht angezeigt. Um sie bearbeiten (ändern, versionieren, löschen) zu können müssen sie aus dem Archiv geholt werden.
Dies ist ganz einfach möglich, indem Sie, wie im Screenshot zu sehen, unter dem Menü „Ansicht“ den Punkt „zeige archivierte“ auswählen.

Sie sehen nun eine Liste der archivierten Datensätze und können diese, mit Hilfe eines Doppelklicks, in der Detailansicht bearbeiten.

Ein archivierter Eintrag ist nun in der Detaildarstellung durch ein kleines Symbol oben rechts gekennzeichnet.

Löschen

Selektiere Datensätze werden gelöscht, diese sind damit physikalisch gelöscht und können nicht wieder hergestellt werden.

Ansicht

Symbolleiste

Anzeige der Symbolleiste ein- bzw. ausschalten.

Gruppiere Sparten

Wechsel von der sequentiellen Anzeige (Standardformular) in den Anzeigemodus mit Registerkarten (Anwendungsspezifisches Formular) und zurück.

Abb.3: Ansicht / Standardformular
Abb.4: Ansicht / Gruppierte Sparten – Anzeigemodus mit Registerkarten

Liste

Wechsel von der Detailansicht in die Listenansicht.

Details

Wechsel in der Detailansicht vom Änderungsmodus in den Anzeigemodus. Keine Datenänderung möglich.

Bearbeiten

Wechsel in der Detailansicht vom Anzeigemodus in den Änderungsmodus. Daten können geändert werden.

Ansicht zurücksetzen

Zurücksetzen sowohl der Auswahl der Daten als auch Anzeige der Daten auf default.

Extras

Formular

Auswahl des gewünschten Formulars.(Standardformular oder Anwendungsspezifisches Formular) In der Demo-Anwendung finden Sie ein Formular beispielsweise beim Kunden in der Detailansicht.

Berichte

Auswahl des gewünschten Berichtes. Beispiel für einen Bericht in der Detailansicht kann ein Produktdatenblatt sein.

Wiedervorlage

Datensatz zur erneuten Bearbeitung wieder vorlegen. Eine Wiedervorlage wird im Media-Menü angezeigt. Wiedervorlage

Mit der Wiedervorlage wird definiert, wann ein Datensatz (Vorgang) zur erneuten Bearbeitung vorgelegt werden soll. Dabei wird auch festgelegt welcher User, bzw. welche Usergruppe die Wiedervorlage angezeigt bekommen.

Es kann entweder ein Zeitraum (z.B. 2 Tage) oder ein absolutes Datum mit Uhrzeit vorgegeben werden. Es können ein oder mehrere Anwender bzw. Anwendergruppen ausgewählt und ein Hinweistext eingegeben werden.

Bestehende Wiedervorlagen werden in dem Eingabefenster angezeigt und können durch klick auf das neben dem Wiedervorlage-Termin angezeigte Symbol mit dem Kreuz gelöscht werden.

Vergleiche mit (nur bei Versionierung)

Vergleichen der aktuellen Version eines Datensatzes mit einer älteren Version. Eingabe der Versionsnummer, mit welcher der aktuellste Datensatz verglichen werden soll. Die Änderungen werden feldweise in einem Fenster angezeigt.
Feldname, alter und neuer Feldinhalt werden dargestellt.

Abb.5: Extras/Vergleiche mit

Das Ergebnis kann auch als pdf dargestellt und gespeichert werden.

Abb.6: Extras/Vergleiche mit – zeige als pdf

Benutzerrechte

Falls vom Admin die Rechte an einer bestimmten Tabelle oder Zeile vergeben wurden, kann man selbst (unter Extras → Benutzerrechte) verschiedene Rechte an ausgewählte Benutzer vergeben:

lesen

bearbeiten

löschen.

Dateien → BILD

Ablegen von Bildern und Dateien.

Abb.7: Ablage von Bildern

SONDERFÄLLE : Es können auch Dateien zum Datensatz abgelegt werden. Dies kann entweder über das Menü EXTRAS->DATEI->BILD oder die normale Eingabemaske erfolgen. Man kann bis zu 10 Dateien gleichzeitig hinzufügen. In dem folgenden Beispiel sollen 3 Dateien eingefügt werden. Dazu wird die Anzahl von 1 auf 3 geändert.

Abb.8: 1 Zeile für die Auswahl von Dateianhängen

Nach Bestätigung der Eingabe stehen 3 Zeilen für die Auswahl von Dateianhängen zur Verfügung.

Abb.9: 3 Zeilen für die Auswahl von Dateianhängen

Klick auf Durchsuchen, die entsprechende Datei auswählen, anschließend auf übernehmen um die Dateianhänge zu speichern.

Gepackte Dateien können beim Hochladen entpackt werden.

Abb.10: Dateien können beim Hochladen entpackt werden

Detaildarstellung Symbolleiste

Abb.11: Detaildarstellung Symbolleiste
  1. Änderungen speichern [STRG][SHIFT][s]
  2. Datensatz Detailansicht
  3. Datensatz anlegen
  4. Datensatz kopieren
  5. Datensatz versionieren
  6. Datensatz löschen
  7. Datensatz archivieren
  8. Datensatz Liste [STRG][SHIFT][l]
  9. Berichte
  10. Formular
  11. als Wiedervorlage markieren, bzw bestehende Wiedervorlage löschen

Detaildarstellung der Symbole für Verknüpfungen

Im Folgenden werden die verschiedenen Symbole, die für Verknüpfungen möglich sind, beschrieben. Sie sehen diese in der Demo-Anwendung, zum Beispiel in der Detailansicht zu einem Auftrag.

Erzeuge Verknüpfung

Es wird ein neuer Datensatz angelegt und verknüpft.

Im Datensatz Stadtverwaltung werden nun 3 Verknüpfungen mit den entsprechenden Kontakten Schmidt, Müller und Huber angezeigt.

Verknüpfung bearbeiten

Wechsel vom Bearbeitungsmodus in den Ansichtsmodus und zurück. Im Bearbeitungsmodus können die Felder des verknüpften Datensatzes direkt geändert werden.

Datensatz suchen

Suche nach einem bereits verknüpften Datensatz. Nach Klick auf das Symbol werden die möglichen Suchfelder oberhalb der Überschrift eingeblendet, mit erneutem klick wieder ausgeblendet. Es wird nur innerhalb der verknüpften Datensätze gesucht.
Eingabe von Teilstrings ist möglich. Es stehen alle Suchfunktionen der Listenansicht zur Verfügung. Beschreibung siehe LISTENANSICHT -> BEARBEITUNGSMENÜ -> BEARBEITEN -> SUCHEN

Öffne Verknüpfung

Es wird ein Fenster geöffnet, in dem die verknüpften Datensätze in der Listenansicht der Tabelle angezeigt werden. Hier können Verknüpfungen auch gelöst werden, ohne dass der Datensatz gelöscht wird.Es können auch weitere Datensätze erzeugt und verknüpft werden.

Auswahl Anzeigefelder

Auswählen der Felder, die angezeigt werden

Löschen der angezeigten Verknüpfungen

Löscht die angezeigten Verknüpfungen und den entsprechenden Datensatz!

Ändern der Sortierreihenfolge der angezeigten Verknüpfung

Anklicken eines Pfeiles – die Verknüpfung wird in der Sortierung um eine Stelle nach oben bzw unten bewegt (abhängig von der Pfeilrichtung).

Detaildarstellung kontextabhängige (feldtyp-abhängige) Symbolleisten

Sortierung der angezeigten Verknüpfungen kann durch einen Klick auf die Überschrift verändert werden. Klick auf Vorname, es wird nach Vorname aufsteigend sortiert. Erneuter klick auf Vorname und es wird nach Vorname absteigend sortiert.
Um wieder nach Nachname zu sortieren einfach auf die Überschrift Nachname klicken.

Symbolleiste Verknüpfungen Tabellen

Abb.12: Symbolleiste Kontakte Sortier
  1. Erzeuge Verknüpfung
  2. Verknüpfung bearbeiten
  3. Datensatz suchen. Suchfelder oberhalb der Überschrift werden nur angezeigt, wenn für die angezeigten Felder die SCHNELLSUCHE aktiviert ist.
  4. Öffne Verknüpfung
  5. Auswahl Anzeigefelder
  6. Löschen der angezeigten Verknüpfungen und des verknüpften Datensatzes
  7. Reihenfolge der angezeigten Verknüpfung ändern. Mit Klick auf einen der Pfeile wird die Verknüpfung um eine Zeile nach oben/unten verschoben.

Diese Sortierung kann durch einfachen klick auf den einzelnen Pfeil am linken Rand neben der Überschrift (in Abb 10 links neben Nachname) immer wiederhergestellt werden.

Abhängig von der Art der Verknüpfung gibt es das Symbol „Verknüpfung lösen“ (Alternative zu 6; siehe rechts). Hier wird die Verknüpfung nur gelöst, der verknüpfte Datensatz bleibt bestehen.
HINWEIS:Die Darstellung (Breite) der Datenfelder, z. B. der Nachname im Beispiel, entspricht den Einstellungen der Listenansicht der entsprechenden Tabelle.
Wurden dort individuelle Einstellungen vorgenommen, wirken sich diese auch auf die Darstellung der Verknüpfungen aus.

Symbolleiste Verknüpfungen Termine

Abb.13: Symbolleiste Termine
  1. Erzeuge Verknüpfung
  2. Verknüpfung bearbeiten
  3. Öffne Verknüpfung
  4. Auswahl Anzeigefelder
  5. Verknüpfung im Kalender anzeigen

Symbolleiste Verknüpfungen Mails

Abb.14: Symbolleiste Korrespondenz
E-Mail1 Erzeuge Verknüpfung
2 Datensatz verknüpfen
3 Öffne Verknüpfung
4 Auswahl Anzeigefelder
Korrespondenz5 Erzeuge Verknüpfung
6 Verknüpfung bearbeiten
7 Datensatz suchen

Symbolleiste Verknüpfungen Dateien

Abb.15: Symbolleiste Dateien
1. Mini DateimanagerHochladen und Verwalten von Dateien die in LIMBAS gespeichert werden (siehe detaillierte Beschreibung des Mini-Dateimanagers)
2. neuer OrdnerAnlegen eines neuen Ordners. Ordnername eingeben und auf „anlegen“ klicken
3. neue DateiDoppelklick auf den Ordner, in den die neue Datei hinzugefügt werden soll. Neue Datei anklicken, Datei im Verzeichnis suchen, auswählen und hinzufügen
4. Datei löschenDatei markieren, Symbol anklicken. Datei wird gelöscht
5. Verknüpfung entfernenEs wird die Verknüpfung zur Datei gelöscht, die Datei bleibt erhalten
6. Auswahl der angezeigten Felder
7. zeige alle DateienEs werden alle verknüpften Dateien angezeigt, unabhängig vom Verzeichnis, in dem sie abgelegt sind
8. einfache DarstellungEs werden nur Order / Dateien angezeigt, ohne Details wie z.B. Datum oder Dateigröße
9. BildershowMiniaturansicht aller Bilder. Einfacher Mausklick zum Vergrößern eines Bildes
10. BildergalerieEs wird ein Bild angezeigt. Blättern mit den angezeigten Pfeiltasten
11. Suchen möglichSuchen nach zu verknüpfenden Dateien