Record List Edit Menu

Geschätzte Lektüre: 9 Minuten

Record List – Edit Menu

The Record List displays data records of a table. The Menu Bar and Toolbar provide all the commands to select data records, customize the view, add new data records, edit , delete, ‘version’ or archive data records. You can also create reports or export the data.

File

Save

Modification will be saved.

Create New

Create a new data record.

2 variations are possible. The ADMIN defines per table which variation is used.

Variation 1:

After selecting File -> Create New , a window appears with the question :’ Do you want to create a new record?’ When confirmed with OK, a Data record ID will be assigned and an empty data record is created. This data record can now be edited. It is not recommended to create empty data records.

Variation 2:

After selecting File -> Create New, a window appears with the question:’ Do you want to create a new record?’ When confirmed with OK, an input mask appears to enter the data. The data records will only be created after you choose ‘Save’.

Copy

Selected data records are copied, but only the data fields defined by the ADMIN will be copied.

Print

The print function of your browser will be activated. The screen contents will be printed or saved to a file.

Lock

Selected data records can be locked for a certain period. The period can be specified in minutes, hours or days. Locked data records are listed in Reports or in the Record List, but cannot be edited. To get an overview about locked data records, click on the User Function Profile Locked Data. There you can also easily unlock these data records.

Versioning

This command is only available, when this functionality is enabled for a table. Versioning means, that a data record exists various times and can have different versions. This can be used eg. for different prices of an article. Version 1 contains the original price, version 2 the new price.

Archive

Selected data records will be archived. Archived data records are not listed in Reports or in the Record List. To edit (change, version or delete) an archived data record you have to recover it.

Delete

Selected data records will be deleted. They are physically deleted and cannot be restored.

Edit

(or double click in a search field)

(Example of the search for details)

Search within the current table for one or more search terms, in one or more fields. In the ‘Detail Search’ window you can select the field you want to search in. You can search with a specific search term.

You have also the possibility to restrict the search for part of the data field, e. g the beginning.

CScase sensitive to be considered (CS = case sensitive)
Negationnegates the query

A field can be searched by multiple search terms.

The operator AND / OR controls whether all terms have to be true or just one of them.

ANDAll search criteria for this field have to be fulfilled
OROnly one of the search criteria for this field have to be fulfilled

To start the search click on the Search button. You will see your search term also in the search field above the column header. You can select more than one field for your search. You can expand a list of these search criteria.

With Global AND / OR you define the Boolean operator between the search results of fields.

ANDAll search conditions of all fields have to be fulfilled
OROnly search conditions of one of the fields have to be fulfilled

This setting is relevant for all fields!

Reset Selection and Filter

Reset of selected data records, resets all data records, including the search queries and sort criteria, to default settings.

Select All

Select all displayed data records.

Edit List

Editing of data records in the Record List. Certain data fields can be edited in the Record List. (links and long fields can’t be edited). This function enables you to quickly update several data records. Don’t forget to save the modifications. Return to’ view only mode’ by clicking again on Edit -> Edit List.

Stack Processing

Simultaneously modify multiple records. The command appears only in the Edit Menu, when this function is enabled for this table. When Stack Processing is enabled by the ADMIN, he also defines for which table fields this functionality can be used. After choosing ‘Stack Processing’ only the relevant fields are displayed. Make sure you have selected the data records you want to modify. If no data records are selected, the changes will take effect in ALL DATA RECORDS! You can select individual data records, or use the search function.

View

The commands shown in the Menu ‘View’ can vary from table to table. Where a data record cannot be versioned, the command ‘Show Versioned’ will not appear. If the command ‘Show Versioned’ is chosen, the text ‘Show Versioned’ will appear in grey with a tick to its right.

Toolbar

Hide or unhide toolbar.

Default Width

Reset column width to default values.

Show Archived

Show archived data records or hide them (hide = default)

Show Locked Data

Displays only locked data records.

Hide Locked Data

Locked data records will not be displayed.

Show Versioned

Displays all versions of versioned data records. In order to show the versioned records you must be in the record list. Go to the menue view and click “show versioned”. The table now shows all records, versioned or not. All versions of one item are shown after each other. There is now a new column in the table which shows the version number of the record. If you have a versioned record this record is red.

Show Sum

Shows sum of value fields. The sum is taken only from the values of the records displayed.

Extras

Reports

Creating reports. Depending on your application various reports can be available for a table. After selecting the required report, the format of the output file has to be specified. The following formats are available:

  • .pdf
  • .odt
  • .xml

The report can be saved (archived) or a preview can be first displayed and then be saved.
A report that, for example, creates a list of customers from the customers table, will contain all displayed customers (number of hits in the footer). A report that creates invoices will create invoices only for selected data records. Please note that all invoices will be in one file.

The Print button allows you to print the report directly to the selected printer after it has been created.

Snapshot

A snapshot is a search query that is saved and can be used again. Extensive or complicated search queries or frequently used one’s, needed to be created only once and can be reused. A snapshot can be shared with other users. When a snap shot is published it is available in the Navigation Menu. User specific search queries can be:

  • Saved
  • Published
  • Edited
  • Administrated

To save a snap shot go to Extras ->Snapshot -> Save As and choose a name for the snapshot. You will now find this name in your Workplace to start the search query direct.

Go to Extras -> Snapshot -> Administrate to edit, publish or delete a snap shot. A published snap shot can be used by other users. These can be defined individually or via user groups. The user or user group can get the right to:

  • Use a snapshot
  • Edit a snapshot
  • Delete a snapshot

A snapshot can also be administered in My Profil / Snapshot. There you will also find a detailed description Snapshot.

(A deleted snapshot will only disappear in the Navigation Menu after a reset is performed)

Export

Export datarecords
Choose format

  • Exel
  • XML

Select datarecords for export
Shown – only the data records displayed on the screen will be exported
alle – all data records will be exported (number of hits in the footer)

A window then appears (content depends on the browser used).

Select if the result

  • is saved as a file
  • opens with a program to select

Setting the path Formulate the browser’s DOWNLOAD DIRECTORY.

User Rights

If the rights to a specific table or line have been assigned by the admin, you can assign different rights to selected users: (Extras → User rights):

read

edit

delete

Special Features

! Disable Limitation

Force Delete

This command is only available to a small group of users. Example: Data record ‘customer’ is linked to a data record ‘contact’. Data record customer will be deleted. With Force Delete, also the data record ‘contact’ can be deleted (providing ‘contact’ has no further links)

Toolbar Record List

  1. Save Changes
  2. Create Record
  3. Copy Record
  4. Delete Record
  5. Archive Record
  6. Search Record
  7. Edit List
  8. Show archived Records
  9. Reports
  10. Delete Search and Filter Criteria
  11. Global Search

Global Search

Other than the the field-specific search fields, where only the respective field is searched, in the global search all fields of the table are searched.

Share this Doc

Record List Edit Menu

Or copy link

CONTENTS